Version 1 (modified by ecoughlan, 3 years ago) (diff)


Code Critique - Erin and Becca

  • windowEntry imports text, image, and rectangle, so this is duplicate code
  • Coding style is easy to maintain because there are comments before if/elif statement
  • Commenting is consistent with the code, but some sections are missing comments (load, save)
  • Variable names are self-explanatory and have meaningful names
  • Error checking "success" in load and save for errors
  • "success" variable is currently unused, but is in the process of being developed
  • Variable names are too similar sometimes. For example, "window" vs. "windows"
  • isInstance(building, Building), which is confusing
  • Differences between static and dynamic windows
    • Check all windows at one time and create necessary ones
  • if case for "windows" response should be first in the list
  • In general, reorder response cases